Blog de Linux, Redes Cisco, Iron Maiden y algo de mi vida….

Solucionar el problema al desinstalar el paquete “adobe-flashplugin”

Estos días he tenido problemas al reproducir videos flash en Ubuntu Karmic (los controles no funcionan en Chrome), y creí que desinstalar el reproductor de flash y volverlo a instalar solucionaría el problema, pero cuando intenté desinstalarlo me aparecía el siguiente error:

E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
Escribiendo información de estado extendido… Hecho
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.

Entonces dije “bueno, entonces descarguemos el .deb y reinstalemos!” y creyendo que habia dominado el mundo Linux con esta idea descargué el paquete y cuando intenté instalarlo obtuve este error:

sudo dpkg -i install_flash_player_10_linux.deb
Seleccionando el paquete adobe-flashplugin previamente no seleccionado.
(Leyendo la base de datos … 00%
118156 ficheros y directorios instalados actualmente.)
Preparando para reemplazar adobe-flashplugin 10.0.22.87-1 (usando install_flash_player_10_linux.deb) …
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: warning: script de `pre-removal’ antiguo returned error exit status 2
dpkg – probando el script del nuevo paquete en su lugar…
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error al procesar install_flash_player_10_linux.deb (–install):
el subproceso script pre-removal nuevo devolvió el código de salida de error 2
postinst called with argument `abort-upgrade’
dpkg: error al reorganizar:
el subproceso installed post-installation script devolvió el código de salida de error 1
Se encontraron errores al procesar:
install_flash_player_10_linux.deb

Ahí me dí cuenta que la cosa no era tan fácil… buscando en google encontré la solución, aquí va:

Editar el archivo que controla el estado de los paquetes:

sudo gedit /var/lib/dpkg/status

Luego buscamos Package: adobe-flashplugin

Entonces borramos toda la informacion de este paquete (borra hasta donde aparece Package: xxxxxxx de nuevo – xxxxx es el nombre de algún paquete-)

Luego guardas el archivo y ejecutas

sudo apt-get update

Y ya podemos desinstalar dicho paquete. Luego me dí cuenta que el problema no era de flash, sino de Chrome😀, pero bueno, por lo menos si tienes un problema con otro paqueteya tienes una idea de qué hacer para borrarlo.

Up the Irons

Fuente: EspacioLinux

12 comentarios

  1. Atarrulfo

    Creo que con un millón de gracias me quedo corto, compañero!!!
    Muchíiiiiiiiiiisimas gracias!, me estaba volviendo LOCO para solucionar este problema con el adobe-flashplayer.
    Saludos.

    noviembre 10, 2009 en 8:35 pm

    • Yo también me estaba volviendo loco con ese problema, menos mal ya lo solucionamos.

      Saludos!!

      noviembre 10, 2009 en 8:47 pm

  2. aberth

    muchas gracias, en algunos momentos estas cosas te salvan de una buena.. gracias compañero..
    saludos!!!!!!!!

    noviembre 11, 2009 en 5:48 pm

  3. manvehe

    Realmente gracias, tenía el mismo problema.

    noviembre 12, 2009 en 5:53 pm

  4. mil gracias!

    Muchas gracias!!! pude solucionarlo por finnnnnnnnnnnnnnnnnnnnn!!!

    noviembre 19, 2009 en 7:15 pm

  5. Gracias

    muchisimas gracias….

    noviembre 25, 2009 en 11:57 pm

  6. mat

    muchas gracias por fin pude hacer lo que hace tiempo no podia…

    diciembre 1, 2009 en 6:41 pm

  7. jose

    muchisisisisisimas gracias amigo !!!

    diciembre 9, 2009 en 8:49 am

  8. hey men le pegaste súper bien con el tutoría, me ha servido de mucho y de verdad me ha sido de mucha ayuda !

    enero 8, 2010 en 8:56 pm

  9. Leo

    Muchisimas gracias por esta ayuda, todo funciona de maravilla

    junio 2, 2011 en 9:15 am

  10. Ricardo

    Muchas Gracias por la ayuda!

    mayo 30, 2012 en 11:34 am

  11. crunch

    Sensei despues de tanto batallar y leer muchos posts.

    este es el unico que me sirvio, asi que este es el post que deben llevar a cabo

    agosto 27, 2012 en 10:43 am

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s