Blog de Linux, Redes Cisco, Iron Maiden y algo de mi vida….

Ubuntu en Toshiba Satellite A215-S4747

Toshiba Satellite A215 S4747

Hace ya un tiempo me regalaron un portátil Toshiba Satellite A215-S4747. Es un muy buen equipo, 200Gb de disco duro, tarjeta de video de 128 MB, procesador AMD Turion de doble núcleo… Pueden ver aquí un review (en inglés) de este equipo. Pero no todo es tan bueno como lo pintan… El ÚNICO defecto es que trae Windows Vista preinstalado. Intenté quedarme con él (lo juro) pero a la semana le tomaba casi 5 minutos en apagarse!! Decidí entonces hacer un downgrade a XP. Todo iba bien hasta que empezó a apagarse solo… Parecía que el disco duro se apagaba de un momento a otro… Fue entonces cuando decidí instalar Ubuntu en él (no es mi primera experiencia con ubuntu, ya lo había instalado en el Desktop de mi casa). Y así fue como lo hice:

– Primero, conseguir ubuntu: Descargué la versión alternate del siguiente enlace:

http://mirror.pop-sc.rnp.br/mirror/ubuntu/gutsy/ubuntu-7.10-alternate-i386.iso

Obviamente hay más versiones, las pueden ver aquí. Aún no entiendo muy bien la diferencia entre un OS de 32 y uno de 64 bits. Más adelante les explicaré (espero). Descargué la versión alternate, que es una versión que no incluye el Live CD. Lo hice así porque la versión normal me traía problemas con la tarjeta de video.

Después de instalado, proseguí a instalar mi tarjeta de video.

– Segundo, instalar la tarjeta de video: Fué muy fácil ya que ubuntu en sus controladores restringidos me dió la opción de instalarle mi tarjeta de video (una ati radeon 1200 express). Vas aqui primero…

Y en la siguiente ventana esogen el driver de la tarjeta de video:

Reiniciamos y debemos ver el cambio inmediatemente. Si queremos efectos compiz (cubo de escritorio y esas cosas) debemos instalar el paquete “xserver-xgl”. Cómo? abre el gestor de paquetes synaptic (Sistema / Administración / Gestor de paquetes synaptic), y busca el paquete en mención, lo instalamos, y editamos el archivo xorg.conf. Lo abrimos así por medio de la línea de comandos:

$ sudo gedit /etc/X11/xorg.conf

Y al final ingresamos esto:

Section "Extensions"
Option "Composite" "1"
EndSection

Reiniciamos y luego ingresamos a Sistema / Preferencias / Apariencia y eligimos personalizado.

Para activar la opcion de preferencias de gtk, buscamos en el gestor de paquetes de synaptic “compizconfig-settings-manager“. Y listo. Ahí pueden ya configurar su escritorio como más les parezca.

– Tercero, instalación de la tarjeta de red inalambrica: hhmmm… aquí debo tomar aire porqueme costó mucho trabajo instalarla… Bueno, lo que deben hacer es esto: ir al gestor de controladores restringidos, deshabilitar el driver de la tarjeta de red, reiniciar, descargar este paquete. Lo descomprimen y van a la carpeta que contenga el driver que necesiten (me refiero a que si instalaron ubuntu de 32 bits pues usan el driver de 32 bits). Abrimos la consola e ingresamos:

sudo rmmod ath_pci  sudo gedit /etc/modprobe.d/blacklist

Y añadimos al final del archivo blacklist ath_pci, y lo guardamos. Reiniciamos y despues abrimos synaptic, buscamos “ndiswrapper” e instalamos diswrapper-common y ndiswrapper-utils-1.9. Después, vamos a la carpeta que donde esta el driver que vamos a utilizar, e ingresamos

sudo ndiswrapper -i net5211.inf
sudo ndiswrapper -m
sudo modprobe ndiswrapper

Abrimos el archivo modules asi

sudo gedit /etc/modules

y agregamos ndiswrapper al final del archivo. Reiniciamos y debemos tener el ícono de redes inalámbricas en la esquina superior derecha de nuestro escritorio.

– Lo demás, el sonido, puertos USB, lector de tarjetas funcionan de una. Para usar la cámara instale Cheese! desde synaptic y ya debemos tener nuestro Satellite funcionando perfectamente en Ubuntu.

Up the Irons!!

13 comentarios

  1. levy

    hola que tal soy levy. al momento de instalar me aparese este error:
    installing net 5211 …
    couldn’t open net5211.inf: No existe el fichero ó directorio at /usr/sbin/ndiswrapper-1.9 line 181.
    como le puedo hacer si realice paso por paso.

    noviembre 10, 2008 en 4:56 pm

  2. Hola Levy, pásate por este enlace [1] ya que después de actualizar mi kernel mi tarjeta inalámbrica ya no iba. Pruébalo y me cuentas.

    [1] https://onoametal.wordpress.com/2008/11/02/wifi-en-toshiba-satellite-a215-s4747-con-ubuntu-hardy/

    Espero te sirva!

    noviembre 10, 2008 en 6:58 pm

  3. arturo

    hola soy arturo .. soy un poco nuevo en ubuntu yo tengo el disco de la version 7.10 y lo actualize a 8.04 . pero el problema es q no he podido activar mi tarjeta de wireless tengo una lap toshiba a215 muy similar a la q mencionan anteriormente. utilice el gestor de paquetes e instale el q se refiere a q funcionen los driver de windows en linux asi q puse este archivo q es para los wireless pero me dice q no tiene o q no esta activado net5211.inf
    . mi pregunta es si es necesariamente desde la terminal. o en dado caso q me diga q no hay dispositivo tendre q cambiar la tarjeta de wireless… porfa comprendanme soy nuevo .. pero ya me arte de windows…
    por su ayuda grasias.

    diciembre 27, 2008 en 1:50 pm

  4. arturo

    hola onoametal .. grasias por la ayuda. pero q crees me surgio otro problema. ya la tarjeta me funciono me detecta la red ingreso la clave pero mi dice q ya estoy conectado .. pero cuando trato de navegar .no puedo . no me abre ninguna pagina. revise los detalles de la coneccion y en todos los datos ,.. el ip, el dns , la mascara., y todo eso. me marca en ceros .. pero la puse en automatico . no se q me este haciendo falta. o si algo hice mal… me pueden ayudar nuevamente..
    grasias por la atencion

    enero 3, 2009 en 11:50 pm

  5. Que raro…. asegúrate que tienes la configuración de tu equipo por DHCP (automático), y que tu red esta en modo infraestructura. Tienes como probar si tu router esta dando direcciones Ip a la red inalambrica? Sería bueno si puedes descartar una falla por ahí con otro portátil. O si hiciste doble boot en tu equipo inicia con windows e intenta conectarte a la red y me cuentas si funciona o no.

    Saludos,

    enero 4, 2009 en 9:45 am

  6. arturo

    ya probe varias formas… mi hermano tiene una pc con windows y tambien esta por wireless y esa si se conecta.. probe de igual forma e instale la version 8.10 y esa me detecto mi wireless automaticamente y puedo ver las redes q hay si la puse en dhcp . checo los detalles de la red y si tiene ip , dns , mascara y todo eso `pero se me hace muy extraño porque cuando intento navegar no me deja. tarda en cargar la pagina pero no la abre. y marca error.

    a tambien un punto importante es q me pide varias veses ingresar la clave. y me dice q estoy conectado. pero nada.

    ya actualice el sistema con el gestor. no se q paquetes necesite mas.

    enero 4, 2009 en 9:53 pm

  7. Oye, dos preguntas

    Instalaste la tarjeta con ndiswrapper o con madwifi? Usa el metodo de madwifi. Adicional, que tpo de seguridad usas en tu red? WAP o WEP? Yo tuve problemas con WEP (me pedia contraseña cada rato, como a ti) y la puse en WAP y ya funciona muy bien. Revisa ambas cosas y me dices, a ver que podemos hacer.

    Saludos,

    enero 5, 2009 en 11:36 am

  8. arturo

    disculpa por no ser tan claro …jeje y esq tambien no se si de plano me falla feo pero feooo…!! jsjsjs..
    ok . fue una instalacion limpi de ubuntu 8.10 y me reconocio todo el hardware de la makina.
    y si mi red tiene seguridad wep voy a probar con wap haber como me va.
    actualize el sistema pero conectandola con cable

    pregunta.. tendria q instalarlo con madwifi o ya no es necesario.??
    voy a probar cambiando la wep a wap a ver q pasa… ahi te cuanto..

    grasias por toda la ayuda–!🙂

    enero 5, 2009 en 1:37 pm

  9. Hola Arturo

    Pues si te reconoció la tarjeta inalámbrica yo creo que no habría que reinstalarla, pero no te aseguro nada. Yo instalé con madwifi mi tarjeta porque no la reconoció, así que solo te puedo hablar de una tarjeta funcionando con madwifi. Revisa lo de la seguridad y me cuentas. Espero se solucione!!!

    enero 5, 2009 en 1:46 pm

  10. RUBEN SOLANO FLORES

    TENGOP UNA SATELITTE A215-S4747, EL CASO ES DE QUE YA TIENE TODO INSTALADO, SOLO ME FALTA EL DRIVER DE RED……CABE SEÑALAR QUE LO CAMBIE DE VISTA A XP. DONDE CONSIGO LOS DIVERS PARA RED DE XP……..GRACIAS POR SU AYUDA!

    agosto 31, 2009 en 11:07 pm

    • Ruben, dame hasta mañana y los subo.

      Saludos!

      agosto 31, 2009 en 11:13 pm

  11. Ruben, ya está listo, los puedes descargar de aquí [1]

    Saludos!!

    [1] https://onoametal.wordpress.com/2009/09/01/drivers-winxp-toshiba-satellite-a215-s4747/

    septiembre 1, 2009 en 10:27 am

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s